USN-4164-1: Libxslt vulnerabilities

22 October 2019

libxslt vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

Several security issues were fixed in Libxslt.

Software Description

  • libxslt - XSLT processing library

Details

It was discovered that Libxslt incorrectly handled certain documents. An attacker could possibly use this issue to access sensitive information. This issue not affected Ubuntu 19.10. (CVE-2019-13117, CVE-2019-13118)

It was discovered that Libxslt incorrectly handled certain documents. An attacker could possibly use this issue to execute arbitrary code. (CVE-2019-18197)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
libxslt1.1 - 1.1.33-0ubuntu1.1
Ubuntu 19.04
libxslt1.1 - 1.1.32-2ubuntu0.2
Ubuntu 18.04 LTS
libxslt1.1 - 1.1.29-5ubuntu0.2
Ubuntu 16.04 LTS
libxslt1.1 - 1.1.28-2.1ubuntu0.3
Ubuntu 14.04 ESM
libxslt1.1 - 1.1.28-2ubuntu0.2+esm1
Ubuntu 12.04 ESM
libxslt1.1 - 1.1.26-8ubuntu1.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes. make all the necessary changes.

References