USN-4206-1: GraphicsMagick vulnerabilities

2 December 2019

graphicsmagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in GraphicsMagick.

Software Description

  • graphicsmagick - collection of image processing tools

Details

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-10794, CVE-2017-10799, CVE-2017-11102, CVE-2017-11140, CVE-2017-11403, CVE-2017-11636, CVE-2017-11637, CVE-2017-13147, CVE-2017-14042, CVE-2017-6335)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
graphicsmagick - 1.3.23-1ubuntu0.2
libgraphicsmagick++-q16-12 - 1.3.23-1ubuntu0.2
libgraphicsmagick-q16-3 - 1.3.23-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References