USN-4220-1: Git vulnerabilities

10 December 2019

git vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in Git.

Software Description

  • git - fast, scalable, distributed revision control system

Details

Joern Schneeweisz and Nicolas Joly discovered that Git contained various security flaws. An attacker could possibly use these issues to overwrite arbitrary paths, execute arbitrary code, and overwrite files in the .git directory.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
git - 1:2.20.1-2ubuntu1.19.10.1
Ubuntu 19.04
git - 1:2.20.1-2ubuntu1.19.04.1
Ubuntu 18.04 LTS
git - 1:2.17.1-1ubuntu0.5
Ubuntu 16.04 LTS
git - 1:2.7.4-0ubuntu1.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References