USN-4240-1: Kamailio vulnerability

16 January 2020

kamailio vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS

Summary

kamailio could be made to crash if it opened a specially crafted file.

Software Description

  • kamailio - very fast and configurable SIP proxy

Details

It was discovered that Kamailio can be exploited by using a specially crafted message that can cause a buffer overflow issue.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
kamailio - 4.3.4-1.1ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References