USN-4256-1: Cyrus SASL vulnerability

28 January 2020

cyrus-sasl2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

Cyrus SASL could be made to crash or execute arbitrary code if it received a specially crafted LDAP packet.

Software Description

  • cyrus-sasl2 - Cyrus Simple Authentication and Security Layer

Details

It was discovered that Cyrus SASL incorrectly handled certain LDAP packets. An attacker could possibly use this issue to execute arbitrary code or cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
libsasl2-2 - 2.1.27+dfsg-1ubuntu0.1
Ubuntu 18.04 LTS
libsasl2-2 - 2.1.27~101-g0780600+dfsg-3ubuntu2.1
Ubuntu 16.04 LTS
libsasl2-2 - 2.1.26.dfsg1-14ubuntu0.2
Ubuntu 14.04 ESM
libsasl2-2 - 2.1.25.dfsg1-17ubuntu0.1~esm1
Ubuntu 12.04 ESM
libsasl2-2 - 2.1.25.dfsg1-3ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart services using SASL to effect the necessary changes.

References