USN-3375-1: LXC vulnerability

Ubuntu Security Notice USN-3375-1

2nd August, 2017

lxc vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

LXC would allow unintended access.

Software description

  • lxc - Linux Containers userspace tools

Details

It was discovered that LXC incorrectly handled the TIOCSTI ioctl. An
attacker could possibly use this issue to escape LXC containers.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
lxc 1.0.10-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart LXC containers to make
all the necessary changes.

References

CVE-2016-10124